MarkUs Blog

MarkUs Developers Blog About Their Project

MarkUs UCOSP, Fall 2011: Status Week 11

without comments

Severin

Status:

  • Ran a small scale experiment with MemoryRespository. Not sure if conclusive, but it ran fast and did not show similar behaviour to other experiments with SVN repositories.
  • Unsuccessfully tried to make Phusion Passenger use separate production.log’s per Ruby worker.
  • Sidenote: Mongrel/Passenger performance is pretty much on par

Next Steps:

  • Perhaps create a screencast showing the performance run in action
  • Write-up of findings
  • Time permitting, re-run mongrel experiments with separate production logs per mongrel in order to get more accurate analysis from request-log-analyzer

Roadblocks:

  • Other courses

 

Alex

Status:

  • Added functional tests for students, TAs, rubrics, and annotation_categories to test the multiple encoding file uploads.

Next Steps:

  • Try to figure out how to add remaining functional tests.
  • Figure out why there are errors on the grades file upload. Whether it’s caused by me or by a rails 3 migration.

Roadblocks:

  •  Could not figure out how to add functional tests to grades, groups, graders.
  • Graders and groups do not have a functioning upload/download capability, so I could not test it manually before making the functional tests.

 

Luke

Status:

  • Put up review fixing issue 527 (http://review.markusproject.org/r/1139/).Waiting for Ship It.
  • Fixed misspelling raised by a professor and some translation issues.
  • Got that reviewed. (https://github.com/lkysow/Markus/tree/spelling-fix)
  • Discussed issue 525 (https://github.com/MarkUsProject/Markus/issues/525) with Nelle and got it closed.
  • Started work on issue 501 (https://github.com/MarkUsProject/Markus/issues/501). Waiting on  translations from mailing list.

Next Steps:

  • Bump Ship It on 527.
  • Bump translations needed on 501.
  • Start work on… ahh rvlaicu stole it!

Roadblocks:

  • Need ship it on 527 and translations for 501

Erik

Status:

  • Resolved issue 439: Admins couldn’t create groups with the “Add new” button (Waiting for review. id: 1137)
  • Wrote a blog post about using firebug

Next Steps:

  • Probably continue work on the groups page, still a few broken links/buttons

Roadblocks:

  • None

 

Razvan

Status:

  • No real work done this week.

Next steps:

  • Continue with issues currently allocated to me.

Roadblocks:

  • Final projects for a couple of courses taking significantly more time than expected.

Written by Severin

November 30th, 2011 at 4:55 pm

Leave a Reply